ESXi 5.5 설치시 no network adapter 문제 해결하는 방법

no

 

ESXi 5.0 과 5.1에서 잘 설치되던 것이 새로 나온 5.5에서는 다음과 같은 화면이 나오면서 설치가 안돼는 경우가 있습니다.

이러한 현상은 바로 ESXi 5.0과 5.1에서는 ESXi가 공식적으로 지원하지 않는 NICs 들도 드라이버를 제공했으나

5.5부터는 이 드라이버들을 빼버렸기 때문입니다.

이 방법을 해결하기 위해서는,

 

0. 일단 ESXi 5.1 최신 버전을 설치해놓습니다.

 

1. SSH로 접속합니다. (Putty 등을 이용)

 

putty

 

 

2. 다음의 명령어를 입력합니다.

 

esxcli network firewall ruleset set -e true -r httpClient

 

3. 또 입력
esxcli software profile update -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
-p ESXi-5.5.0-1331820-standard

 

4. 한참을 기다립니다. 넉넉히 30분정도 기다려보세요. 촤라락 업데이트 내용이 나오면서 reboot 하라고 나옵니다.

 

5. reboot 입력.

 

6. vSphere Client 업데이트를 하라고 하고 정상적으로 사용이됩니다.

 

PS. ESXi 5.5에서 저런 화면이 뜨는 NIC 들

‘VMware_bootbank_net-sky2_1.20-2vmw.510.0.0.799733’,
‘VMware_bootbank_net-r8168_8.013.00-3vmw.510.0.0.799733’,
‘VMware_bootbank_net-r8169_6.011.00-2vmw.510.0.0.799733’,
‘VMware_bootbank_net-s2io_2.1.4.13427-3vmw.510.0.0.799733’

 

왜 5.5 버전 부터는 이 드라이버들이 삭제되었는지 모르겠네요..

아무튼 공짜 소프트웨어지만(부분적으로) 정말 귀찮게 합니다.

7 Replies to “ESXi 5.5 설치시 no network adapter 문제 해결하는 방법

  1. esxi 5.1 tx100 후지쯔 배포판으로 설치했음에도 tx100의 nic 두개중 한개만 인식하고 나머지 하나는 인식을 못하는데..(물론 bios에서 둘다 활성화는 했습니다) 위와 같은 방법으로 나머지 하나도 인식하는게 가능할까요? 하나도 인식이 안될때… 사용되는 방법인데… 하나가 인식되는 상황에서 위 방법대로 했을 때. 혹여나 부작용은 없을까 조금 걱정입니다. 그래봐야, esxi 다시 설치하면되긴하지만요.

    그리고, esxi에 대해서 공부를 좀 할만한 책자나 사이트는 없을런지요.
    설치를 하고 조충우돌하며 이것저것 해보고 있습니다만 가장 이해가 안되는 부분이 sdd와 hdd를 할당해주는 부분입니다.
    용어 자체가 생소하다보니, 단순히 이것저것 해보는 것만으로는 부족함이 많은 것 같아 이론적으로 좀 공부가 필요할 것 같아서요.

    사실 가장 쉬운건, tx100의 성능이 괜찮은 편이라 윈7 올린뒤에, 우분투나 xpenology를 가상화로 사용하는 것이지만,
    tx100을 데탑으로 사용할 생각은 없기에 현재 esxi올린뒤에 윈7과 우분투만 올려서 활용해보고자 합니다.

    체험단 일등으로 바쁘시겠지만, 시간이 다소 걸리더라도 여유 있을때 답장좀 부탁드립니다.

    1. 먼저 공부할만한 책은,

      yes24에서 판매하는 ‘인사이드 Vsphere 4’ 입니다.

      http://www.yes24.com/24/goods/4146286?scode=032&OzSrank=1

      오래된 책이지만 기본 맥은 같습니다. 기초부터 공부하시려면 이 책을 읽어보세요.

      그리고 tx100 nic 문제는 제 포스팅으로 해결이 되지 않으실듯 합니다.

      이 포스팅은 5.1에서는 nic가 잡히는데, 5.5에서 안 잡힐경우에 사용하는 방법입니다.

      윤창대님의 경우 5.1에서도 안 잡히기 때문에 위 강좌와는 다른 문제이십니다.

  2. ESXi 6.0을 설치 했습니다.NO network adapters 메세지 이후 서버측에 네트웍이 안 잡혔는데..
    putty로 어떻게 접속하는지 모르겠습니다. 설명의 1번 그림과 같이 192.168.0.100에 접속이 되어 있네요…
    좀더 자세한 설명 부탁드립니다.

댓글 남기기